Back to overview
Resolved

Investigating routing and performance issues

Jun 5, 2026 at 4:29pm UTC  –  Jun 19, 2026 at 4:29pm UTC
Affected services
G01
Authentication

Resolved
Jun 19, 2026 at 4:29pm UTC

Maintenance ended

Updated
Jun 12, 2026 at 4:33pm UTC

Continuing investigation into intermittent errors that began last week (June 5). We are actively narrowing down the root cause.

Created
Jun 5, 2026 at 4:29pm UTC

We are currently seeing a spike in timeouts and dropped connections across the platform. The origin server is under active investigation. Uploads and downloads might be sluggish or require a retry until this is resolved.