Infrastructure Improvements & System Refactoring
Resolved
Jul 21, 2026 at 3:02pm UTC
Maintenance ended
Affected services
Updated
Jul 21, 2026 at 3:02pm UTC
Hypastack's refactor is complete and full service has been restored. Thanks for your patience throughout this maintenance window.
Affected services
Updated
Jul 21, 2026 at 3:00pm UTC
We're approaching the finish line of Hypastack's refactor. The major performance, scalability, and security improvements are now in place, and we're in the final phase of this maintenance window. Thanks for your patience as we evolve Hypastack.
Affected services
Created
Jun 30, 2026 at 9:18pm UTC
We are performing a major architectural refactor of Hypastack to significantly improve performance, scalability, and security. During this maintenance window, service availability may be intermittent. We are committed to completing these upgrades quickly to provide a more robust and faster experience. Thank you for your patience as we evolve Hypastack.
Expected Impact: Temporary unavailability of file uploads and dashboard access. Existing file links will remain accessible.
Affected services